Chance The IT Guy - Ring Group and Queues – Incident details
All systems operational
Ring Group and Queues
Resolved
Operational
Started over 4 years agoLasted about 2 hours
Updates
Resolved
Resolved
We just resolved the issue!
Monitoring
Monitoring
Root cause has been fixed. We are monitoring East network and will roll out our solution to West shortly.
Identified
Identified
We are aware that some customers may be experiencing disruptions to Ring Group and Queues. We have identified the issue and are working on a solution. We will update this page as they become available.